Задать вопрос
20 мая, 06:51

Задача pascal

Даны целочисленные координаты точки на плоскости.

Если точка совпадает с началом координат, то вывести 0.

Если точка не совпадает с началом координат, но лежит на оси ОХ или OY,

то вывести соответственно 1 или 2.

Если точка не лежит на координатных осях, вывести 3. (нужно чтобы прошла тест на taskbook)

+3
Ответы (1)
  1. 20 мая, 07:48
    0
    Var x, y: integer;

    begin

    readln (x, y) ;

    write ('> ') ;

    if ((x = 0) and (y = 0)) then writeln (0) ;

    if ((x 0) and (y = 0)) then writeln (1) ;

    if ((x = 0) and (y 0)) then writeln (2) ;

    if ((x 0) and (y 0)) then writeln (3) ;

    end.

    Проверку на Pascal ABC проходит, а тот сайт не грузится у меня, инет плохой ...)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача pascal Даны целочисленные координаты точки на плоскости. Если точка совпадает с началом координат, то вывести 0. Если точка не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В некотором каталоге хранился файл taskbook. txt. после того, как в этом каталоге создали подкаталог и переместили в созднный подкаталог taskbook. txt. полное имя файла стало C:/does/school/math/taskbook. txt.
Ответы (1)
задача pascal Даны три точки А, В, С на числовой оси. Найти длины отрезков АС и ВС и их сумму. (нужно чтобы прошел тест на taskbook)
Ответы (1)
Даны целочисленные координаты X и Y. Написать программу, которая выводит на экран сообщение "Принадлежит" или "Не принадлежит" эта точка 1-ой четверти координатной плоскости. Точки на осях координат считаются принадлежащими к данной четверти.
Ответы (1)
Pascal Даны координаты точки, не лежащей на координатных осях OX и OY. Определить номер координатной четверти, в которой находится данная точка.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)