Задать вопрос
3 сентября, 17:00

Дано целое четырехзначное число. Вычислить произведение его цифр (создать программу на паскале)

+3
Ответы (1)
  1. 3 сентября, 17:06
    0
    Program proga;

    var a:integer;

    Begin

    readln (a) ;

    writeln ((a div 1000) * (a mod 1000 div 100) * (a mod 1000 mod 100 div 10) * (a mod 1000 mod 100mod 10)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое четырехзначное число. Вычислить произведение его цифр (создать программу на паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2). 3. Дано целое число А.
Ответы (1)
Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр.
Ответы (1)