Задать вопрос
20 июля, 08:02

47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя

48 дано целое четырехзначное положительное число n. составьте программу, которая определяет, кратно ли пяти произведение его цифр

+5
Ответы (1)
  1. 20 июля, 09:07
    0
    var

    n:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    if (n mod 10) > ((n div 100) mod 10) then

    writeln ('Последняя больше второй')

    else

    if (n mod 10) < ((n div 100) mod 10) then

    writeln ('Вторая больше последней')

    else

    writeln ('Они равны') ;

    readln;

    end.

    / / Вторая программа

    var

    n, Pr:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    Pr : = 1;

    while n > 0 do

    begin

    Pr : = Pr * (n mod 10) ;

    n : = n div 10;

    end;

    writeln ('Pr = ', Pr) ;

    if Pr mod 5 = 0 then

    writeln ('Кратно')

    else

    writeln ('Некратно') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Помогите создать программку через Visual studio C++ Дано трехзначное число. Определить, какая из его цифр больше: а) первая или последняя; б) первая или вторая; в) вторая или последняя.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)