Задать вопрос
8 августа, 13:28

Дано натуральное число N. Требуется определить количество нулей среди цифр данного числа.

+5
Ответы (1)
  1. 8 августа, 16:32
    0
    Var

    n:longint;

    k:integer;

    begin

    Write ('Введите натуральное число: ') ; Read (n) ;

    k:=0;

    while n>0 do begin

    if (n mod 10) = 0 then Inc (k) ;

    n:=n div 10

    end;

    Writeln ('Количество нулей в числе равно ', k)

    end.

    Тестовое решение:

    Введите натуральное число: 15035003

    Количество нулей в числе равно 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. Требуется определить количество нулей среди цифр данного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число N (N> 9). Определить количество нулей в цифровой записи числа, кроме нулей в младших разрядах. Пример. N=10 025 000. Количество нулей равно двум.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)