Задать вопрос
4 марта, 07:24

Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр.

+4
Ответы (1)
  1. 4 марта, 07:41
    0
    Var

    sum, com, n:integer;

    begin

    Read (n) ; sum:=0; com:=1;

    while (n > 0) do begin

    sum: = sum + n mod 10;

    com: = com * (n mod 10) ;

    n: = n div 10;

    end;

    Writeln ('Сумма - > ', sum) ;

    Writeln ('Произведение - > ', com) ;

    end.

    Пример:

    1234

    Сумма - > 10

    Произведение - > 24
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)