Задать вопрос
23 марта, 07:23

Найти номер строки и номер столбца максимального элемента матрицы, в delphi

+4
Ответы (1)
  1. 23 марта, 09:55
    0
    Var a, i, j, b, p, p1, max:longint;

    m:array[0 ... 501,1 ... 500] of longint;

    begin

    read (a, b) ;

    for i:=1 to a do

    for j:=1 to b do

    read (m[i, j]) ;

    p:=1;

    p1:=1;

    max:=m[1,1];

    for i:=1 to a do

    for j:=1 to b do

    if m[i, j]>max then

    begin

    p:=i;

    p1:=j;

    max:=m[i, j];

    end;

    writeln (p,' ', p1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти номер строки и номер столбца максимального элемента матрицы, в delphi ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)