Задать вопрос
25 июня, 09:28

Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, rabbit, dragon, snake, horse, sheep, monkey).

Формат входных данных:

Входной файл содержит натуральное число

Формат выходных данных:

В выходной файл выведите ответ на поставленную задачу.

+2
Ответы (1)
  1. 25 июня, 11:10
    0
    Var

    x, y:integer;

    a:array [1 ... 12] of string;

    begin

    a[1]:=cock;

    ...

    a[12]:=monkey;

    read (x) ;

    y: = (abs (2016-x)) mod 12;

    write (a[y]) ;

    end.

    Вроде должно работать. Проверить не могу - сижу с телефона
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано два натуральных числа N и M. Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно. Формат входных данных: Входной файл input.
Ответы (1)
Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... 9899. Формат входных данных Файл содержит число k-позиция искомой цифры.
Ответы (1)
Дан год. Вывести на экран название животного, символизирующего заданный год по восточному календарю. Выполнить надо желательно с оператором case.
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Условный оператор. Задача 5 Даны три целых числа. Определить, имеется ли среди них хотя бы одна пара равных между собой чисел. Формат входных данных Входной файл содержит три целых числа через пробел.
Ответы (1)