Задать вопрос
6 октября, 05:06

Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... 9899. Формат входных данных Файл содержит число k-позиция искомой цифры. Формат выходных данных Выходной файл содержит искомую цифру. Пример входных и выходных файлов Task1. in Task1. out 4 1 8 3

+2
Ответы (1)
  1. 6 октября, 07:44
    0
    Var k: integer;

    f: Text;

    begin

    assign (f, 'Task1. in') ;

    reset (f) ;

    readln (f, k) ;

    close (f) ;

    assign (f, 'Task1. out') ;

    rewrite (f) ;

    if (k mod 2 = 0) then

    writeln (f, ((k-1) div 2) mod 10)

    else

    write (f, (k div 2) div 10 + 1) ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано два натуральных числа N и M. Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно. Формат входных данных: Входной файл input.
Ответы (1)
На жестком диске было 12 папок, в 5 из них было по 8 файлов, а оставшихся по 10 файлов. После перегруппировки всех файлов стало 11 папок с равным количеством файлов. Количество файлов не изменилось.
Ответы (2)
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)