Задать вопрос
27 июня, 18:44

Дано два натуральных числа N и M.

Написать программу для определения

наименьшего из чисел, составленных из цифр данных чисел. Незначащих

нулей в найденном числе быть не должно.

Формат входных данных:

Входной

файл input. txt содержит два натуральных числа N (10 < = N <=

10^100) и M (10 < = M < = 10^100), разделенных одним пробелом.

Формат выходных данных:

Выходной файл output. txt должен содержать найденное наименьшее число.

+2
Ответы (1)
  1. 27 июня, 20:06
    0
    Var x, y:longint;

    g, f: text;

    begin

    assign (g, 'input. txt') ;

    assign (f, 'output. txt') ;

    reset (g) ;

    read (g, x, y) ;

    close (g) ;

    rewrite (f) ;

    if x
    if x>y then write (f, y) ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано два натуральных числа N и M. Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
файл 1 txt хранится в папке txt 1 вложенной в папку txt находящейся на диске d каким является полный путь к файлу Варианты: 1) 1 2) / 1. txt 3) D:/ 4) / txt 5) txt
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Файл input. txt: Мама, короче, мыла, короче, раму. Декан, короче, пропил, короче, бутан. А роза, короче, упала на лапу, короче, Азора. Каждый, короче, охотник желает, короче, знать, где короче сидит фазан В файле input.
Ответы (1)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)