Задать вопрос
14 декабря, 17:53

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC

+2
Ответы (2)
  1. 14 декабря, 18:56
    0
    Var

    s:string;

    i, n:byte;

    p:boolean;

    begin

    Write ('Введите слово: ') ;

    Readln (s) ;

    n:=Length (s) ;

    p:=true;

    for i:=1 to n div 2 do

    if s[i]s[n-i+1] then

    begin

    p:=false;

    break

    end;

    if p then Writeln ('Палиндром')

    else Writeln ('Не палиндром')

    end.
  2. 14 декабря, 19:04
    0
    var

    s: string;

    function Invert (s: string) : string;

    var

    i: integer;

    t: string;

    begin

    t : = '';

    for i : = 1 to length (s) do

    t : = s[i] + t;

    Invert : = t;

    end;

    begin

    Write ('Введите слово: ') ;

    Readln (s) ;

    s : = Trim (s) ;

    s : = Uppercase (s) ;

    if Invert (s) = s then

    Writeln ('Палиндром')

    else

    Writeln ('Не палиндром') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)