Задать вопрос
12 марта, 20:45

Написать программу, которая запрашивает коэффициенты квадратного уравнения и сообщает, сколько корней имеет уравнение. Pascal ABC

+4
Ответы (1)
  1. 12 марта, 22:41
    0
    Var

    a, b, c, d:real;

    begin

    Write ('Введите коэффициенты уравнения a, b, c: ') ;

    Readln (a, b, c) ;

    d:=b*b-4*a*c;

    if d<0 then Writeln ('Корней нет')

    else if d=0 then Writeln ('Один корень')

    else Writeln ('Два корня')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая запрашивает коэффициенты квадратного уравнения и сообщает, сколько корней имеет уравнение. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, которая запрашивает с клавиатуры целое число и сообщает "Четное" или "Нечетное" это число. Pascal ABC
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)