Задать вопрос
5 мая, 17:04

Ввести двузначное целое число х<15. Написать программу перевода его в восьмеричную систему счисления. (Паскаль)

+3
Ответы (1)
  1. 5 мая, 19:14
    0
    Const zs='01234567'; / / цифры в 8 СС

    s:string;

    begin

    write ('Введите число в 10 СС: ') ;

    readln (n) ;

    s:='';

    while n>0 do

    begin

    s:=zs[n mod 8+1]+s; / / берем остаток от деления на 8 и эту цифру пишем в начало строки

    n:=n div 8 / / сокращаем число

    end;

    write ('Число в 8 СС: ', s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести двузначное целое число х ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)
Помогите с прогой. Паскаль. Ввести массив, ввести кол-во элементов в массиве (не через рандом). Ввести число. Найти сколько элементов равны этому числу. (ввод массива и кол-ва эл. Через процедуры)
Ответы (1)