Задать вопрос
7 августа, 18:33

Первое задание

дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры

второе задание

дано целое трёхзначное число x. составьте программу вычисления суммы и произвидения цифр трёхзначного числа x. значение x ввести с клавиатуры

+5
Ответы (1)
  1. 7 августа, 19:50
    0
    1)

    var x, y:integer;

    begin

    readln (x) ;

    y: = (abs (x) mod 10) * 10 + (abs (x) div 10) ;

    if x<0 then y:=-y;

    writeln (y) ;

    end.

    Пример:

    -25

    -52

    2)

    var x, x1, x2, x3:integer;

    begin

    readln (x) ;

    x:=abs (x) ;

    x1:=x div 100;

    x2:=x div 10 mod 10;

    x3:=x mod 10;

    writeln ('S = ', x1+x2+x3,' P = ', x1*x2*x3) ;

    end.

    Пример:

    271

    S = 10 P = 14
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Дано целое двузначное число x выведите число полученное при перестановке его цифр значение x ввести с клавиатуры
Ответы (1)
Дано целое двузначное число х выведите число полученное при перестановке его цифр значение х введите с клавиатуры
Ответы (1)
Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры
Ответы (1)