Задать вопрос
25 октября, 11:28

Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры

+5
Ответы (1)
  1. 25 октября, 11:35
    0
    var

    n, p, s, i: integer;

    begin

    s : = 0; p : = 1;

    readln (n) ;

    while n > 0 do

    begin

    i : = n mod 10;

    s : = s + i;

    p : = p * i;

    n : = n div 10;

    end;

    writeln ('Сумма: ', s, ' Произведение:', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано целое двузначное число х. Составьте программу вычисления суммы и произведения цифр числа х. Значение х любое.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)