Задать вопрос
5 апреля, 18:23

Дано целое двузначное число х. Составьте программу вычисления суммы и произведения цифр числа х. Значение х любое.

+3
Ответы (1)
  1. 5 апреля, 21:02
    0
    Var

    x:integer;

    begin

    Write ('x=') ; Read (x) ;

    x:=Abs (x) ; { вдруг число отрицательное }

    Writeln ('Сумма цифр числа равна ', x div 10 + x mod 10) ;

    Writeln ('Произведение цифр числа равно ', (x div 10) * (x mod 10))

    end.

    Пример

    x=-73

    Сумма цифр числа равна 10

    Произведение цифр числа равно 21
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое двузначное число х. Составьте программу вычисления суммы и произведения цифр числа х. Значение х любое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)