Задать вопрос
25 ноября, 18:28

Помогите с прогой. Паскаль. Ввести массив, ввести кол-во элементов в массиве (не через рандом). Ввести число. Найти сколько элементов равны этому числу. (ввод массива и кол-ва эл. Через процедуры)

+3
Ответы (1)
  1. 25 ноября, 19:59
    0
    Var a:array [1 ... 100] of integer;

    k, i, n, x:integer;

    begin

    k:=0;

    writeln ('Введите количество элементов массива') ;

    read (n) ;

    writeln ('Введите число') ;

    read (x) ;

    for i:=1 to n do begin

    read (a[i]) ;

    if a[i]=x then k:=k+1;

    end;

    writeln ('Колиечество элементов равных числу ', x,' = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с прогой. Паскаль. Ввести массив, ввести кол-во элементов в массиве (не через рандом). Ввести число. Найти сколько элементов равны ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)