Задать вопрос
27 ноября, 10:14

Используя признаки делимости, написать программу в паскале, которая проверяет, делится ли натуральное число k на 4 (две последние цифры нули или образуют число, делящееся на 4).

+2
Ответы (1)
  1. 27 ноября, 11:31
    0
    Program qwerty;

    var k, a:integer;

    begin

    readln (k) ;

    a:=k mod 100;

    if (a=0) or (a mod 4=0) then write ('Да')

    else write ('Нет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Используя признаки делимости, написать программу в паскале, которая проверяет, делится ли натуральное число k на 4 (две последние цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6. var a, c: integer; begin cls; randomize; a:=random (99999+99999+1) - 99999; writeln ('исходное числo: ', a) ;
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность
Ответы (1)
Очень нужна помощь! Составить программу, которая проверяет делится ли введенное число на 3 и выводит на экран "Делится" или " Не делится" (оператор while)
Ответы (1)
Написать программу на Паскале которая запрашивает трёхзначное число, затем с помощью функций Div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". Если да, то печатает "имеется" иначе "не имеется
Ответы (1)