Задать вопрос
12 декабря, 22:24

Написать программу на Паскале которая запрашивает трёхзначное число, затем с помощью функций Div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". Если да, то печатает "имеется" иначе "не имеется

+3
Ответы (1)
  1. 12 декабря, 23:26
    0
    Var N, k, y: integer;

    begin

    write ('Введите число: ') ;

    readln (N) ;

    k : = 0;

    repeat

    y : = N mod 10;

    if y = 5 then k : = k + 1;

    N : = N div 10;

    until N = 0;

    if k 0 then writeln ('Имеется')

    else writeln ('Не имеется')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале которая запрашивает трёхзначное число, затем с помощью функций Div mod разделяет число на цифры и проверяет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике