Задать вопрос
24 апреля, 00:21

Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6.

var a, c: integer;

begin cls;

randomize;

a:=random (99999+99999+1) - 99999;

writeln ('исходное числo: ', a) ;

if (a mod 10) mod 2 = 0 then

writeln (' делится на 2')

else

writeln (' не делится на 2') ;

while a0 do

begin

c: = c + (a mod 10) ;

a: = a div 10;

end;

if c mod 3 = 0 then

writeln (' число делится на 3')

else

writeln (' число не делится на 3') ;

end.

признак делимости на 6 - это значит, что число делится на 2 и 3. я сделала по отдельности на 2 и 3 (программа выше). а как это обобщить?

+1
Ответы (1)
  1. 24 апреля, 01:45
    0
    Var

    a, c: integer;

    begin

    randomize;

    a : = random (99999 + 99999 + 1) - 99999;

    writeln ('исходное числo: ', a) ;

    while a > 0 do

    begin

    c : = c + a mod 10;

    a : = a div 10;

    end;

    if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then

    writeln (' число делится на 6')

    else

    writeln (' число не делится на 6') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6. var a, c: integer; begin cls; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике