Задать вопрос
16 апреля, 21:13

Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность

+4
Ответы (1)
  1. 17 апреля, 00:24
    0
    Program E4;

    var a, b, с: real;

    begin

    writeln ('введите длины трех сторон треугольника ') ;

    readln (a, b, с) ;

    write ('треугольник со сторонами ', а, Ь, с) ;

    if (а + b > с) and (b + с > a) and (а + с > Ь) then

    begin

    writeln ('существует') ;

    if (a = b) and (a = c) then

    writeln ('равносторонний')

    else

    writeln ('неравносторонний') ;

    else

    writeln ('не существует') ;

    end;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)
Программисты помогайте) Написать программу на паскале, которая по заданным трем числам определяет, является ли сумма каких-либо двух из них положительной
Ответы (1)
Составить алгоритм вычисления площади треугольника по трем заданным сторонам с проверкой на существующий данный треугольник (по формуле Герона)
Ответы (1)
Составить программу в паскале используя функции или процедуры, которая будет вычеслять площадь треугольника по трем сторонам. в программе выполнить проверку существования треугольника
Ответы (1)
Написать программу, которая по трем заданным углам треугольника определяет и выдаёт на экран вид этого треугольника На Pascal
Ответы (1)