Задать вопрос
7 июня, 02:46

Составить алгоритм вычисления площади треугольника по трем заданным сторонам с проверкой на существующий данный треугольник (по формуле Герона)

+2
Ответы (1)
  1. 7 июня, 03:04
    0
    Паскаль

    var a, b, c, S, p:real;

    label e;

    begin

    e: a:=0; b:=0; c:=0; read (a, b, c) ;

    if ((a+b) < = c) or ((a+c) < = b) or ((b+c) < = a) then

    begin

    writeln ('Такого треугольника не существует, введите стороны заново') ;

    goto e;

    end;

    if ((a+b) > c) or ((a+c) > b) or ((b+c) > a) then

    begin

    p: = (a+b+c) / 2;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('Площадь треугольника = ', S) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм вычисления площади треугольника по трем заданным сторонам с проверкой на существующий данный треугольник (по формуле ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Задача по теме "Линейный алгоритм". Pascal ABC Найти площадь треугольника по известным трем сторонам (по формуле Герона).
Ответы (2)
Помогите решить практическую работу Тема"Линейные и разветвляющиеся алгоритмы" Дан треугольник со сторонами a, b, c. Вычислить площадь треугольника по трем сторонам (формула Герона).
Ответы (1)
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)
Составить словесный алгоритм и блок-схему нахождения площади треугольника по формуле Герона, если известны все три стороны
Ответы (1)