Задать вопрос
5 февраля, 00:56

Написать программу, которая по трем заданным углам треугольника определяет и выдаёт на экран вид этого треугольника

На Pascal

+2
Ответы (1)
  1. 5 февраля, 01:42
    0
    Var a, b, c: integer;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('b = ') ;

    readln (b) ;

    write ('c = ') ;

    readln (c) ;

    if a + b + c 180 then

    writeln ('Треугольник не существует') else

    if (a = 180) or (b = 180) or (c = 180) then

    writeln ('Треугольник вырожденный') else

    if (a = 90) or (b = 90) or (c = 90) then

    writeln ('Треугольник прямоугольный') else

    if (a > 90) or (b > 90) or (c > 90) then

    writeln ('Треугольник тупоугольный')

    else writeln ('Треугольник остроугольный') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая по трем заданным углам треугольника определяет и выдаёт на экран вид этого треугольника На Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Программисты помогайте) Написать программу на паскале, которая по заданным трем числам определяет, является ли сумма каких-либо двух из них положительной
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)