Задать вопрос
25 февраля, 08:30

Ввести положительные и отрицательные элементы квадратной матрицы и перезаписать все положительные элементы в одномерный массив. Вывести одномерный массив.

+5
Ответы (1)
  1. 25 февраля, 09:13
    0
    const nx = 20;

    var x: array[1 ... nx, 1 ... nx] of integer; z:array[1 ... nx*2] of integer;

    i, j, k, n, r, t: integer;

    begin

    Writeln ('Введите размер матрицы n') ; Read (n) ;

    for i : = 1 to n do begin

    for j : = 1 to n do begin

    Read (k) ; x[i, j] : = k; end; end;

    Writeln ('Исходный массив') ;

    for i : = 1 to n do begin

    for j : = 1 to n do begin

    Write (x[i, j]:4) ;

    if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j]; end;

    end;

    Writeln; end;

    Writeln; Writeln ('Одномерный массив') ;

    for j : = 1 to t do

    Write (z[j]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести положительные и отрицательные элементы квадратной матрицы и перезаписать все положительные элементы в одномерный массив. Вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Ввести одномерный массив А из 12 элементов. Определите в нём среднее геометрическое квадратов нечетных чисел. 2) Ввести одномерный массив А из N элементов. Каждый элемент, чей модуль больше 10, обнулить. Массив вывести до и после преобразования.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)