Задать вопрос
1 февраля, 19:45

Из заданной строки получить новую заменив в ней все символы после первой звездочки (*) знаком "-" (если в строке нет звездочек оставить без изменения). Распечатать полученную строку. На паскале

+4
Ответы (1)
  1. 1 февраля, 21:46
    0
    Var

    S: string;

    i: byte;

    tmp: boolean;

    begin

    write ('Введите строку: ') ; readln (S) ;

    for i : = 1 to Length (S) do

    begin

    if ((S[i] = '*') and (tmp = false)) then

    begin

    S[i] : = '-';

    tmp : = true;

    end;

    if tmp = true then S[i] : = '-';

    end;

    writeln (S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из заданной строки получить новую заменив в ней все символы после первой звездочки (*) знаком "-" (если в строке нет звездочек оставить без ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от знака решотка дважды. Вывести на экран, полученную новую строку.
Ответы (1)
Паскаль. Получить новую строку, заменив после первой * знаком - все последующие символы
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)