Задать вопрос
29 августа, 11:10

Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от знака решотка дважды. Вывести на экран, полученную новую строку.

+3
Ответы (1)
  1. 29 августа, 14:34
    0
    var a:string;

    i, j:integer;

    begin

    readln (a) ;

    while pos ('#', a) 0 do delete (a, pos ('#', a),1) ;

    for i:=1 to length (a) do

    for j:=1 to 2 do

    write (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка. Преобразовать ее, удалив каждый символ * и повторив каждый символ, отличный от *. (Паскаль)
Ответы (1)
Составьте программу позволяющую удвоить каждый символ заданной строки и вывести полученную строку на экран
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)