Задать вопрос
26 мая, 14:25

Дана строка. Преобразовать ее, удалив каждый символ * и повторив каждый символ, отличный от *. (Паскаль)

+4
Ответы (1)
  1. 26 мая, 14:35
    0
    Var s, s1:string; k:char; i:integer;

    begin

    readln (s) ;

    readln (k) ;

    s1:='';

    for i:=1 to length (s) do

    if s[i]k then s1:=s1+s[i]+s[i];

    writeln (s) ;

    writeln (s1) ;

    readln; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка. Преобразовать ее, удалив каждый символ * и повторив каждый символ, отличный от *. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от знака решотка дважды. Вывести на экран, полученную новую строку.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)