Задать вопрос
29 декабря, 18:56

Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. Как

только будет введено отрицательное число, суммирование прекратить.

+2
Ответы (1)
  1. 29 декабря, 20:51
    0
    Var

    A, S: real;

    Begin

    S : = 0;

    Write ('Введите последовательность чисел: ') ;

    Read (A) ;

    While A > = 0 do

    Begin

    S : = S + A;

    Read (A) ;

    End;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. Как только будет введено отрицательное число, суммирование ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)