Задать вопрос
7 марта, 13:48

1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for.

2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры. Концом последовательности служит ввод отрицательного числа. Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

+2
Ответы (1)
  1. 7 марта, 17:48
    0
    1)

    var

    n, i, s:integer;

    begin

    s : = 0;

    readln (n) ;

    if n mod 2 = 0 then

    n : = n div 2 - 1

    else

    n : = n div 2;

    for i : = 0 to n do

    begin

    s : = s + (1+2*i)

    end;

    write (s)

    end.

    2)

    var

    a, s: integer;

    begin

    s : = 0;

    read (a) ;

    while (a > = 0) do

    begin

    s : = s + a;

    read (a)

    end;

    writeln;

    write (s)

    end.

    var

    a, s: integer;

    begin

    s : = 0;

    a : = 0;

    repeat

    s : = s + a;

    read (a)

    until a < 0;

    writeln;

    write (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Дано действительное число A. Требуется найти первое значение числа N, при котором сумма S=1+1/2+1/3+ ...+1/N превышает A. Программу составьте двумя способами: используя цикл с предусловием и цикл с постусловием. В ABC Pascal
Ответы (1)