Задать вопрос
8 декабря, 07:08

Дано

действительное число A. Требуется найти первое значение числа N, при

котором сумма S=1+1/2+1/3+ ...+1/N превышает A. Программу

составьте двумя способами: используя цикл с предусловием и цикл с постусловием. В ABC Pascal

+5
Ответы (1)
  1. 8 декабря, 07:46
    0
    Var a, s: real; i: longint;

    begin

    readln (a) ;

    {С предусловием}

    i : = 2;

    s : = 1;

    while (s < = a) do

    begin

    s : = s + 1 / i;

    i : = i + 1;

    end;

    writeln (i - 1) ;

    {С постусловием}

    i : = 1;

    s : = 0;

    repeat

    s : = s + 1 / i;

    i : = i + 1;

    until (s > a) ;

    writeln (i - 1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано действительное число A. Требуется найти первое значение числа N, при котором сумма S=1+1/2+1/3+ ...+1/N превышает A. Программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)