Задать вопрос
11 сентября, 19:44

Дано натуральное число n. Вычислить сумму n членов последовательности

(1/2), (3/4), (5/6), (7/8) ...

+4
Ответы (1)
  1. 11 сентября, 22:25
    0
    Program n1;

    var n, i: integer;

    sum: real;

    begin

    readln (n) ;

    i:=1;

    repeat

    sum:=sum+i / (i+1) ;

    i:=i+2;

    until i>2*n;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Вычислить сумму n членов последовательности (1/2), (3/4), (5/6), (7/8) ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Даны натуральное число n и последовательность целых чисел а1, а2, ..., аn ... Определить количество тех членов последовательности, которые нечетны. Найти сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.
Ответы (1)