Задать вопрос
11 сентября, 18:49

Используя алгоритмический язык, составить алгоритм для вычисления z=x^2+y^2 где х = [1; 2] с шагом h=0,1 и y = [2; 3] с шагом h=0,2.

+3
Ответы (1)
  1. 11 сентября, 22:19
    0
    Const x0=1; xk=2; h1=0.1; y0=2; yk=3; h2=0.2;

    var x, y, z:real; i, j:integer;

    begin

    x:=1-h1;

    for i:=1 to round ((xk-x0) / h1) + 1 do

    begin

    x:=x+h1;

    y:=2-h2;

    for j:=1 to round ((yk-y0) / h2) + 1 do

    begin

    y:=y+h2;

    z:=x*x+y+y;

    writeln (x:3:1, y:5:1, z:7:3) ;

    end;

    end;

    end.

    Результат:

    1.0 2.0 5.000

    1.0 2.2 5.400

    1.0 2.4 5.800

    1.0 2.6 6.200

    1.0 2.8 6.600

    1.0 3.0 7.000

    1.1 2.0 5.210

    ...

    2.0 2.6 9.200

    2.0 2.8 9.600

    2.0 3.0 10.000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Используя алгоритмический язык, составить алгоритм для вычисления z=x^2+y^2 где х = [1; 2] с шагом h=0,1 и y = [2; 3] с шагом h=0,2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Используя алгоритмический язык, составить алгоритм произведения 8 натуральных чисел.
Ответы (1)
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal) 1. С клавиатуры вводятся три целых числа.
Ответы (2)
Составьте программу вычисления первых десяти членов последовательности, заданной формулой n-го члена: xn=3^n-5 еще блок-схема нужна и алгоритмический язык
Ответы (1)