Задать вопрос
4 апреля, 07:10

Напишите как решать

Ниже на 5 языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает число l. Укажите наибольшее нечетное число х, при вводе которого алгоритм печатает 102.

var x, l, m:integer;

begin

readln (x) ;

d:=x;

l:=30;

m:=456;

while l<=m do begin

l:=l+d;

m:=m-5*d;

end;

writeln (l) ;

end.

Алгоритм решения нужен

+2
Ответы (1)
  1. 4 апреля, 09:06
    0
    Алгоритм содержит ошибку: необъявленную переменную d. Фактически она вообще не нужна, потому что d=x и не меняется.

    Выводится значение l, которое вычисляется по формуле l=30+kx, где k - количество выполнений тела цикла while.

    Получаем уравнение 30 + k·x = 102 → k·x = 72.

    Но 72 = 2 * 2 * 2 * 3 * 3 если значение х нечетное, то оно может быть или 3, или 3 * 3 = 9.

    В вопросе спрашивается о максимальном х, поэтому проверим, подходит ли х=9.

    В этом случае k = 72 / 9 = 8

    Значение k определяется условием выполнения цикла l ≤ m,

    где m = 456 - 5·x·k.

    При k = 8 получаем 102 ≤ 456 - 5*8*9; 102 ≤ 96 - ложно,

    но еще при k=7 получаем 30+7*9 ≤ 456-5*7*9; 93 ≤ 141 истинно.

    Следовательно, x=9 подходит.

    Ответ: 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите как решать Ниже на 5 языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает число l. Укажите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13.
Ответы (1)
Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при вводе которых алгоритм печатает сначала 7, а потом 29.
Ответы (1)
Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.
Ответы (1)
Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 18.
Ответы (1)
Var x, L, M: integer; begin readln (x) ; L : = x - 16; M : = x + 16; while L M do if L > M then L : = L - M else M : = M - L; writeln (M) ; end. 20 (№ 424) Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает число M.
Ответы (1)