Задать вопрос
5 октября, 23:01

Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 18.

var x, a, b: integer;

begin readln (x) ; a : = 0; b : = 1;

while x > 0 do begin a : = a+1;

b : = b * (x mod 100) ;

x : = x div 100;

end;

writeln (a) ;

write (b) ;

end.

+2
Ответы (1)
  1. 6 октября, 01:04
    0
    Procedure GetAB (x: integer; var a: integer; var b: integer) ;

    begin

    a : = 0;

    b : = 1;

    while x > 0 do

    begin

    a : = a + 1;

    b : = b * (x mod 100) ;

    x : = x div 100;

    end;

    end;

    var

    x, a, b: integer;

    begin

    for x : = 10000 to 2000000000 do

    begin

    GetAB (x, a, b) ;

    if (a = 3) and (b = 18) then

    Println (a, b, x) ;

    end;

    end.

    выдает такие значения

    3 18 10118

    3 18 10209

    3 18 10306

    3 18 10603

    3 18 10902

    3 18 11801

    3 18 20109

    3 18 20303

    3 18 20901

    3 18 30106

    3 18 30203

    3 18 30302

    3 18 30601

    3 18 60103

    3 18 60301

    3 18 90102

    3 18 90201

    3 18 180101

    Выделенное наибольшее
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при вводе которых алгоритм печатает сначала 7, а потом 29.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Объясните строчку (c:=10*c+a mod 10; a : = a div 10;) program pr36; function qwer (var a, b: integer) : integer; var c: integer; begin c:=0; while a > 0 do begin c:=10*c+a mod 10; a : = a div 10; end; qwer: = c; end; var a, b: integer;
Ответы (1)
Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4. Var x, L, M: integer; begin readln (x) ; L:=0; M:=0; while x>0 do begin L:=L+1 If M< (x mod 5) then Begin M:=x mod 5 End X:=x div 5; End. Writeln (L) ; write (M) ; End
Ответы (1)