Задать вопрос
24 марта, 01:39

Умоляю, помогите ...

Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм

печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при

вводе которых алгоритм печатает сначала 7, а потом 29.

mod - озгачает остаток от деления нацело, например, 10 mod 3 равно 1 (mod (10,3) = 1), div - деление нацело, например, (10 div 3 = 3 (div (10,3) = 3)

Паскаль

var x, a, b, c: integer;

begin

readln (x) ;

a : = 9; b : = 0;

while x>0 do

begin

c : = x mod 10;

b : = b+c;

if c < = a then a : = c;

x : = x div 10;

end;

writeln (a) ; write (b) ;

end.

+5
Ответы (1)
  1. 24 марта, 02:57
    0
    Программа получает на вход натуральное число, затем подсчитывает сумму его цифр и определяет наименьшую из всех цифр, кроме первой.

    В соответствии с условием задачи требуется найти наибольшее четырехзначное число, сумма цифр которого равна 29, а наибольшая из трех последних цифр не превышает 7.

    Итак, одна из цифр числа известна - это 7. Тогда сумма остальных трех цифр равна 29-7=22, причем две из этих цифр не могут быть меньше 7. Полагаем, что они равны 7 с тем, чтобы получить наибольшую допустимую первую цифру. Получаем 22-7 х2=8, т. е. число должно быть равно 8777.

    Ответ: 8777
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.
Ответы (1)
Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 18.
Ответы (1)
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)