Задать вопрос
21 января, 22:42

Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

var х, L, M: integer;

begin

readln (x) ;

L: = 0; M : = 1;

while x>0 do

begin

L : = L + 1;

M : = M * (x mod 8) ;

х : = x div 8;

end;

writeln (L) ; write (M) ;

end.

+2
Ответы (1)
  1. 22 января, 01:37
    0
    Ответ: 428

    нашел с помощь программы

    var

    x, L, M, i:integer;

    begin

    for i : = 4096 downto 1 do

    begin

    L : = 0;

    M : = 1;

    x : = i;

    while x > 0 do

    begin

    Inc (L) ;

    M : = M * (x mod 8) ;

    x : = x div 8;

    end;

    if (L = 3) and (M = 120) then

    begin

    WriteLn ('x = ', i) ;

    break;

    end;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при вводе которых алгоритм печатает сначала 7, а потом 29.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
1. Решите примеры 13 div 5 = 13 mod 5 = 5 div 5 = 5 mod 5 = 3 div 8 = 3 mod 8 = 10 div 6 mod 3 = 2. Определите результат выполнения следующих действий а) a:=1819; b: = (div (а, 100)) * 10 + 9 a: = mod (10*b - a),100) а = ? b = ?
Ответы (1)