Задать вопрос
18 октября, 13:45

Var x, L, M: integer;

begin

readln (x) ;

L : = x - 16;

M : = x + 16;

while L M do

if L > M then

L : = L - M

else

M : = M - L;

writeln (M) ;

end.

20 (№ 424) Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 16.

+4
Ответы (1)
  1. 18 октября, 17:20
    0
    В данной программе реализуется алгоритм поиска наибольшего общего делителя двух чисел (L и M). При этом M больше L на 32, а наибольший делитель чисел равен 16. Первое число > 100, кратное 16 - это 112, но наибольший общий делитель чисел 112-16 и 112+16 (96 и 128) равен 32. Следующее число, кратное 16 - это 128. Наибольший общий делитель 128-16 и 128+16 (112 и 144) = 16.

    Ответ: 128
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Var x, L, M: integer; begin readln (x) ; L : = x - 16; M : = x + 16; while L M do if L > M then L : = L - M else M : = M - L; writeln (M) ; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Какое число будет напечатано в результате выполнения программы: var i, k: integer; function f (x: integer) : integer; var m: integer; begin if x < 10 then f : = x else begin m : = f (x div 10) ; if m < x mod 10 then f : = x mod 10 else f : = m; end;
Ответы (1)
Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13.
Ответы (1)