Задать вопрос
1 мая, 17:01

Написать программу, которая в последовательности трехзначных чисел определяет количество и сумму чисел. Первая и последняя цифра которых одинаковы.

Количество чисел неизвестно. Ввод оканчивается 0. На экране должно быть выведено количество и сумма таких чисел.

+1
Ответы (1)
  1. 1 мая, 18:17
    0
    Var a, s, i, b : integer;

    begin

    readln (a) ;

    while a0 do begin

    readln (a) ;

    s:=s+a;

    i:=i+1;

    end;

    writeln (s,' ', i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая в последовательности трехзначных чисел определяет количество и сумму чисел. Первая и последняя цифра которых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Признаком конца последовательности является ввод 0.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 6 и оканчивающихся на 4. Программа получает на ввод натуральные числа, количество введенных чисел неизвестно.
Ответы (1)