Задать вопрос
5 апреля, 01:56

Составить программу, проверяющую есть ли цифра n в числе, введённом с клавиатуры. Pascal abc.

(не копируйте с других источников, неправильно)

+3
Ответы (1)
  1. 5 апреля, 02:37
    0
    Program n1;

    var a, n: integer;

    f: byte;

    begin

    f:=0;

    readln (a, n) ;

    while a0 do

    begin

    if a mod 10=n then f:=1;

    a:=a div 10;

    end;

    if f=1 then write ('цифра ', n,' присутствует в числе')

    else write ('в числе нет цифры ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, проверяющую есть ли цифра n в числе, введённом с клавиатуры. Pascal abc. (не копируйте с других источников, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Напишите программу: Посчитать количество четных цифр в числе, введенном с клавиатуры. pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)