Задать вопрос
26 сентября, 21:49

Дан целочисленный массив размера N. Удалить из массива все элементы с четными номерами.

Когда из массива "удаляются элементы", то его размер, очевидно, меньше не становится. Просто появляются неиспользуемые ячейки. В таких случаях на экран надо выводить только ту часть массива, в которой остались "неудаленные" элементы.

На Паскале

+4
Ответы (1)
  1. 26 сентября, 22:55
    0
    Var

    a: array [1 ... 1000] of integer;

    i, j, n, k:integer;

    begin

    write ('количество чисел') ;

    read (n) ;

    for i:=1 to n do begin

    read (a[i]) ;

    end;

    for i:=1 to n do begin

    if (a[i] mod 2) = 0 then

    a[i]:=0;

    end;

    for i: = 1 to n do

    if (a[i]>0) then

    writeln (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив размера N. Удалить из массива все элементы с четными номерами. Когда из массива "удаляются элементы", то его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан целочисленный массив A размера N. Найти номера тех элементов массива, которые больше своего правого соседа, и количество таких элементов. Найденные номера выводить в порядке их возрастания. На Паскале
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)