Задать вопрос
19 мая, 22:43

Дан целочисленный массив A размера N. Найти номера тех элементов массива, которые больше

своего правого соседа, и количество таких элементов. Найденные номера выводить в порядке их

возрастания.

На Паскале

+5
Ответы (1)
  1. 20 мая, 00:24
    0
    Const sz=1000;

    var

    a: array [1 ... sz] of integer;

    i, j, n, k:integer;

    begin

    write ('количество чисел') ;

    read (n) ;

    for i:=1 to n do begin

    read (a[i]) ;

    end;

    for i:=1 to n-1 do

    begin

    if (a[i]>a[i+1]) then

    writeln (i) ;

    end;

    end.

    надеюсь это что вам нужно
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив A размера N. Найти номера тех элементов массива, которые больше своего правого соседа, и количество таких ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив размера N. Найти номера тех элементов массива, которые больше своего правого соседа, и количество таких элементов. Найденные номера выводить в порядке их возрастания.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)