Задать вопрос
26 сентября, 23:45

Сформировать массив длиной 10 элементов, заполненный случайным образом, вывести на экран количество положительных, четных чисел

+3
Ответы (1)
  1. 27 сентября, 02:44
    0
    Const

    n=10;

    var

    a:array[1 ... n] of integer;

    i, k:integer;

    begin

    Randomize;

    Write ('Исходный массив: ') ;

    k:=0;

    for i:=1 to n do

    begin

    a[i]:=Random (51) - 25;

    Write (a[i],' ') ;

    if (a[i]>0) and (a[i] mod 2=0) then Inc (k)

    end;

    Writeln;

    Writeln ('Количество четных положительных чисел равно ', k)

    end.

    Контрольный прогон

    Исходный массив: 6 - 13 - 13 - 19 - 18 - 10 - 18 8 - 17 - 4

    Количество четных положительных чисел равно 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив длиной 10 элементов, заполненный случайным образом, вывести на экран количество положительных, четных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)