Задать вопрос
24 сентября, 11:08

Нужна помощь.

введите с клавиатуры 5 положительных целых чисел. вычислить сумму тех из них, которые делятся на 4 и при этом заканчивается на 6. программа должна вывести одно число сумму чисел, кратных 4 и оканчивающихся на 6

+5
Ответы (1)
  1. 24 сентября, 12:28
    0
    Var

    mas : array [1 ... 5] of longint;

    sum : longint;

    i: byte;

    begin

    for i:=1 to 5 do

    begin

    read (mas[i]) ;

    if (mas[i] mod 4 = 0) and (mas[i] mod 10 = 6) then sum:=sum+mas[i];

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна помощь. введите с клавиатуры 5 положительных целых чисел. вычислить сумму тех из них, которые делятся на 4 и при этом заканчивается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 3. Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, выведенных с клавиатуры, кратных 4 и оканчивающихся на 6.
Ответы (2)
Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
Ответы (2)
Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делится на 3 и оканчивается на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)