Задать вопрос
18 января, 05:16

Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20; 20]. Вывести на экран промежуточные результаты, полученные при вычислении значения заданного выражения.

Составить программу для вычисления

T = (R / (Q+1)) + S

R - наименьший элемент массива;

Q - произведение элементов массива с нечетными номерами;

S - количество элементов, лежащих в интервале (A, B) (ввести с клавиатуры).

+4
Ответы (1)
  1. 18 января, 05:32
    0
    Var C:array[1 ... 100] of Integer;

    i, N, Q, R, A, B:integer;

    T:real;

    begin

    Readln (N, A, B) ;

    For i:=1 to N do

    C[i]:=Random (-20,20) ;

    R:=C[1];

    Q:=1;

    For i:=1 to N do

    begin

    If C[i]
    R:=C[i];

    If C[i] mod 2=1 then

    Q:=Q*C[i];

    If (C[i]>A) and (C[i]
    S:=S+1;

    end;

    T: = (R / (Q+1)) + S;

    Writeln (R,' ', Q,' ', S,' ', T) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)