Задать вопрос
5 января, 05:41

Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.

+1
Ответы (2)
  1. 5 января, 07:15
    0
    Var b, I:integer;

    a:array [1 ... 8] of integer;

    begin

    writeln ('введите числа') ;

    for I:=1 to 8 do

    read (a[I]) ;

    b:=0;

    for I:=1 to 8 do

    if (a[I]mod3=0) and

    (a[I]mod10=4) then

    b:=b+1;

    writeln (b) ;

    readln;

    end.
  2. 5 января, 08:15
    0
    Var a1, a2, a3, a4, a5, a6, a7, a8, k:integer;

    begin

    k:=0;

    read (a1, a2, a3, a4, a5, a6, a7, a8) ;

    if (a1>0) and (a2>0) and (a3>0) and (a4>0) and (a5>0) and (a6>0) and (a7>0) and (a8>0) then

    begin

    if (a1 mod 3 = 0) and (a1 mod 10 = 4) then k:=k+1;

    if (a2 mod 3 = 0) and (a2 mod 10 = 4) then k:=k+1;

    if (a3 mod 3 = 0) and (a3 mod 10 = 4) then k:=k+1;

    if (a4 mod 3 = 0) and (a4 mod 10 = 4) then k:=k+1;

    if (a5 mod 3 = 0) and (a5 mod 10 = 4) then k:=k+1;

    if (a6 mod 3 = 0) and (a6 mod 10 = 4) then k:=k+1;

    if (a7 mod 3 = 0) and (a7 mod 10 = 4) then k:=k+1;

    if (a8 mod 3 = 0) and (a8 mod 10 = 4) then k:=k+1;

    writeln (k) ;

    end else

    writeln ('Неверный ввод') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 3. Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, выведенных с клавиатуры, кратных 4 и оканчивающихся на 6.
Ответы (2)
Нужна помощь. введите с клавиатуры 5 положительных целых чисел. вычислить сумму тех из них, которые делятся на 4 и при этом заканчивается на 6. программа должна вывести одно число сумму чисел, кратных 4 и оканчивающихся на 6
Ответы (1)
Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делится на 3 и оканчивается на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)