Задать вопрос
4 ноября, 11:34

Помогите что ли ... Напишите на Паскале программу, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет, верно ли, что все знаки элементов этой последовательности чередуются

+3
Ответы (1)
  1. 4 ноября, 12:37
    0
    Var

    a: integer;

    t, s: boolean;

    begin

    t : = true;

    read (a) ;

    s : = a > 0;

    if a 0 then

    read (a) ;

    while t and (a 0) do

    begin

    t : = (a > 0) s;

    s : = not s;

    read (a)

    end;

    writeln (t)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите что ли ... Напишите на Паскале программу, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10
Ответы (1)
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулем и определяет является ли она возрастающей
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол-во четных положительных чисел в этой последовательности (паскаль, питон)
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)