Задать вопрос
11 сентября, 23:33

Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10

+2
Ответы (1)
  1. 12 сентября, 01:26
    0
    Pascal

    const

    n = 100; / / Максимальное число элементов

    var a : array [1 ... n] of integer;

    L, i, c, s, k : integer;

    begin

    L : = 1;

    c : = 10;

    while c 0 do

    begin

    readln (c) ;

    a[L] : = c;

    L : = L + 1;

    end;

    l : = l - 1;

    k : = 0;

    for i : = 1 to L do

    begin

    c : = a[i];

    s : = 0;

    while c 0 do

    begin

    s : = s + c mod 10;

    c : = c div 10;

    end;

    if s = 10 then

    k : = k + 1;

    end;

    writeln () ;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулем и определяет является ли она возрастающей
Ответы (1)
Помогите что ли ... Напишите на Паскале программу, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет, верно ли, что все знаки элементов этой последовательности чередуются
Ответы (1)
Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол-во четных положительных чисел в этой последовательности (паскаль, питон)
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)