Задать вопрос
14 декабря, 15:45

Треугольник задан длинами сторон. Найти углы треугольника в Паскале

+5
Ответы (1)
  1. 14 декабря, 17:00
    0
    var

    a, b, c: real;

    ugol_alpha, ugol_betta, ugol_gamma: real;

    begin

    write ('введите a: ') ;

    readln (a) ;

    write ('введите b: ') ;

    readln (b) ;

    write ('введите c: ') ;

    readln (c) ;

    if a*a+b*b-c*c=0 then writeln ('Данные не корректны!') else begin

    ugol_aplha : = arccos (- ((sqr (a) - sqr (b) - sqr (c)) / 2*b*c)) ;

    ugol_betta:=arccos (- ((sqr (b) - sqr (a) - sqr (c)) / 2*a*c)) ;

    ugol_gamma:=arccos (- ((sqr (c) - sqr (a) - sqr (b)) / 2*a*b)) ;

    write ('альфа=', ugol_alpha,' бетта=', ugol_betta:0:2,' гамма=', ugol_gamma:0:2) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Треугольник задан длинами сторон. Найти углы треугольника в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачу в Паскале Треугольник задан длинами сторон. Если такой треугольник существует, то сообщить какой он: Равносторонний, равнобедренный или разносторонний
Ответы (1)
Треугольник задан длинами сторон. Найти длины медиан - надо в Паскале
Ответы (1)
выяснить существует ли треугольник с длинами сторон x y z с длинами сторон x, y, z (в треуголнике большая сторона меньше суммы двух других сторон)
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
Даны три произвольных числа a, b, c, значение которых задают длины сторон треугольника. Выведите 0, если нельзя построить треугольник с такими длинами сторон; 3, если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях.
Ответы (1)