Задать вопрос
20 мая, 07:04

Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс. Протес-тировать программу для следующих исходных данных:

а) A=3, B=4, C=5

б) A=1, B=1, C=1

в) A=0, B=4, C=5

г) A=-3, B=6, C=5

д) A=2, B=1, C=8

+2
Ответы (1)
  1. 20 мая, 10:35
    0
    Program a_1;

    var A, B, C:integer;

    begin

    writeln ('Введите стороны треугольника') ;

    readln (A, B, C) ;

    if (A+B>C) and (A+C>B) and (C+B>A)

    then

    begin

    writeln ('Треугольник существует') ;

    writeln;

    end

    else

    writeln ('Треугольник не существует') ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое число А. Если значение А>1, то необходимо увеличить его на единицу, иначе уменьшить на 1. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс.
Ответы (1)
Дано целое число А. Если значение А0, то необходимо уменьшить его на 4. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс.
Ответы (2)
Дано целое число А. Если значение А = 0, то необходимо увеличить его на 3, иначе присвоить А значение, равное 0. Составьте на Паскале программу для решения этой задачи. Программа должна иметь дружественный интерфейс
Ответы (1)
Что обеспечивает взаимодействие между устройствами компьютера? 1) графический интерфейс 2) пользовательский интерфейс 3) командный интерфейс 4) аппаратный интерфейс Выбирите один вариант ответа;)
Ответы (2)
Составить на Паскале программу определения минимума из трёх чисел без использования логических операций. Программа должна иметь дружественный интерфейс (ввод данных осуществляться в режиме диалога).
Ответы (1)