Задать вопрос
22 октября, 02:54

Напишите задачу в Паскале

Треугольник задан длинами сторон. Если такой треугольник существует, то сообщить какой он: Равносторонний, равнобедренный или разносторонний

+5
Ответы (1)
  1. 22 октября, 03:31
    0
    Var a, b, c : real;

    begin

    write ('a=') ;

    readln (a) ;

    write ('b=') ;

    readln (b) ;

    write ('c=') ;

    readln (c) ;

    if (a+b<=c) or (a+c<=b) or (b+c<=a)

    then writeln ('Треугольника не существует')

    else if (ab) and (bc) and (ac)

    then writeln ('Треугольник разносторонний')

    else if (ab) or (bc) then writeln ('Треугольник равнобедренный')

    else writeln ('Треугольник равносторонний') ;

    end.

    Пример:

    a=3

    b=4

    c=6

    Треугольник разносторонний
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите задачу в Паскале Треугольник задан длинами сторон. Если такой треугольник существует, то сообщить какой он: Равносторонний, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три положительных числа. Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника (равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.
Ответы (1)
Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли треугольник с такими длинами сторон.
Ответы (1)
выяснить существует ли треугольник с длинами сторон x y z с длинами сторон x, y, z (в треуголнике большая сторона меньше суммы двух других сторон)
Ответы (1)
Даны три произвольных числа a, b, c, значение которых задают длины сторон треугольника. Выведите 0, если нельзя построить треугольник с такими длинами сторон; 3, если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях.
Ответы (1)
Треугольник задан длинами сторон. Найти длины медиан - надо в Паскале
Ответы (1)