Задать вопрос
19 апреля, 17:45

Треугольник задан длинами сторон. Найти длины медиан - надо в Паскале

+2
Ответы (1)
  1. 19 апреля, 18:53
    0
    Var

    a, b, c, ma, mb, mc: real;

    begin

    read (a) ; read (b) ; read (c) ;

    ma: = (sqrt (2*b*b+2*c*c-a*a)) / 2;

    mb: = (sqrt (2*a*a+2*c*c-b*b)) / 2;

    mc: = (sqrt (2*a*a+2*b*b-c*c)) / 2;

    writeln ('Медиана к стороне a=', ma:17:2) ;

    writeln ('Медиана к стороне b=', mb:17:2) ;

    writeln ('Медиана к стороне с=', mс: 17:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Треугольник задан длинами сторон. Найти длины медиан - надо в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачу в Паскале Треугольник задан длинами сторон. Если такой треугольник существует, то сообщить какой он: Равносторонний, равнобедренный или разносторонний
Ответы (1)
Треугольник задан длинами сторон. Найти углы треугольника в Паскале
Ответы (1)
выяснить существует ли треугольник с длинами сторон x y z с длинами сторон x, y, z (в треуголнике большая сторона меньше суммы двух других сторон)
Ответы (1)
Даны три произвольных числа a, b, c, значение которых задают длины сторон треугольника. Выведите 0, если нельзя построить треугольник с такими длинами сторон; 3, если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях.
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)